CM Kyrios explains the team's plans moving forward!

>> http://forums.maplestory2.nexon.net/discussion/45796/

64-Bit Client Feedback Thread

CMKyriosCMKyrios
MapleStory 2 Rep: 2,865
Posts: 190
Administrator
edited 7:19PM April 16, 2019 in Suggestions and Feedback
Hi Maplers,

We will be updating MapleStory 2 on Wednesday, April 17th at 9:00 AM PDT, to release the new 64-bit option for MapleStory 2. This will not require any downtime, but all players will be required to download the update.

- Update Times -
  • PDT (UTC -7): 9:00 AM
  • EDT (UTC -4): 12:00 PM
  • BRT (UTC -3): 1:00 PM
  • CEST (UTC +2): 6:00 PM
  • AEST (UTC +10): 2:00 AM, April 18th

- What -
  • Releasing the new 64-bit client for MapleStory 2
    • All players will need to download this update, even if you choose to continue to play the 32-bit version
    • Players can select the 64-bit client in the Nexon Launcher prior to starting MapleStory 2 via an option beneath the "Play" button
    • Steam users will be prompted to select their preferred version upon launching MapleStory 2

Once you have an opportunity to try out the new client, we encourage players to post results in this thread. If you run into any technical issues regarding it as well, post that below as well. You can always switch back to the 32-Bit client from the launcher should it prevent you from playing for any reason.

Thanks!
ArurauneNovuhzImKAKAROTONexas

Comments

  • GrooTheWandererGrooTheWanderer
    MapleStory 2 Rep: 300
    Posts: 12
    Member
    Okay did the Download, was not given the option to choose 32 or 64 bit. This was supposed to be under the play button...right?
  • CMKyriosCMKyrios
    MapleStory 2 Rep: 2,865
    Posts: 190
    Administrator
    Okay did the Download, was not given the option to choose 32 or 64 bit. This was supposed to be under the play button...right?

    After doing the download, please restart your Nexon Launcher if you don't see the options under the play button.
  • RiennaRienna
    MapleStory 2 Rep: 220
    Posts: 2
    Member
    edited 11:13AM April 17, 2019
    No Prompts for Steam version either

    Edit: Nvm, its there

    Edit 2: restarted Nexon Launcher twice but still dont see the option. https://i.imgur.com/jxT8Jpj.png

    Edit 3: okay nvm. me dumb dumb, i had to update the game first before restarting. <.< ;
    CMKyrios
  • BotoBoto
    MapleStory 2 Rep: 550
    Posts: 8
    Member
    My game no longer launches at all.
    Did the update, restarted the launcher, restarted computer, and pressing the play button does nothing.
    Toybox
  • RayeRaye
    MapleStory 2 Rep: 410
    Posts: 4
    Member
    Boto wrote: »
    My game no longer launches at all.
    Did the update, restarted the launcher, restarted computer, and pressing the play button does nothing.

    Same for me.
    Toybox
  • EveKitsuneEveKitsune
    MapleStory 2 Rep: 520
    Posts: 2
    Member
    edited 11:52AM April 17, 2019
    Boto wrote: »
    My game no longer launches at all.
    Did the update, restarted the launcher, restarted computer, and pressing the play button does nothing.

    I don't know if it will change something... I had the same issues and I couldn't log in the game because popped out that 'my password was incorrect', while I was already logged in the launcher, so I changed the password... After that suddenly my game started and now it works properly.
    I don't know what happened but after this action my game launched... Maybe you can try! : D
  • RayeRaye
    MapleStory 2 Rep: 410
    Posts: 4
    Member
    EveKitsune wrote: »
    Boto wrote: »
    My game no longer launches at all.
    Did the update, restarted the launcher, restarted computer, and pressing the play button does nothing.

    I don't know if it will change something... I had the same issues and I couldn't log in the game because popped out that 'my password was incorrect', while I was already logged in the launcher, so I changed the password... After that suddenly my game started and now it works properly.
    I don't know what happened but after this action my game launched... Maybe you can try! : D

    For me,there was a notification for me in the top right telling me to refresh. Once I did it started working again.
  • SomeRandomGuySomeRandomGuy
    MapleStory 2 Rep: 460
    Posts: 18
    Member
    edited 12:31PM April 17, 2019
    On steam:
    Had a 100mb patch, cant choose anything, there is a 32 bit option but 32 and "normal launch boots same client.

    edit: closing steam through taskmanager solved issue.
  • xCarterxCarter
    MapleStory 2 Rep: 610
    Posts: 15
    Member
    Getting constant ping spikes after updating + restarting launcher. Would get disconnected from the game from time to time :/
  • ToyboxToybox
    MapleStory 2 Rep: 620
    Posts: 13
    Member
    Same issue as those above, pressing the play button does nothing now. Tried restarting client and verifying installation to no help.
  • CMKyriosCMKyrios
    MapleStory 2 Rep: 2,865
    Posts: 190
    Administrator
    We had a slight technical issue earlier regarding the Nexon launcher and the play button. By now the issues that caused it should have been reverted. If your play button still isn't responding to launch the game, please restart your launcher and if still nothing, write about it here.
  • CMKyriosCMKyrios
    MapleStory 2 Rep: 2,865
    Posts: 190
    Administrator
    Toybox wrote: »
    Same issue as those above, pressing the play button does nothing now. Tried restarting client and verifying installation to no help.

    Could you try killing the Nexon launcher application from your task manager and opening it again to see if that helps?
  • ToyboxToybox
    MapleStory 2 Rep: 620
    Posts: 13
    Member
    edited 1:57PM April 17, 2019
    CMKyrios wrote: »
    Toybox wrote: »
    Same issue as those above, pressing the play button does nothing now. Tried restarting client and verifying installation to no help.

    Could you try killing the Nexon launcher application from your task manager and opening it again to see if that helps?

    Working now, thanks!

    Edit: Spoke too soon, getting lots of stuttering and frame drop.
  • MikanBoxMikanBox
    MapleStory 2 Rep: 1,270
    Posts: 18
    Member
    Heres what i got:
    when im in 32bit mode: cdev, 10 people, people turned on: I get 27-45 fps
    same settings, 64bit mode: 42-57 fps
    So that's a nice improvement

    Only issue is the game stutters/hitches a bit too often now.
    If the stutter issue can be fixed, 64bit would be really nice :3
    Novuhz
  • NovuhzNovuhz
    MapleStory 2 Rep: 1,415
    Posts: 106
    Member
    Yep I'm getting some random 0 fps spikes, like it's loading something then it doesn't get stutter/spikes anymore.

    But fps went up to the point I can even enable player models now.
  • ElzaYuukiElzaYuuki
    MapleStory 2 Rep: 1,460
    Posts: 33
    Member
    Works great after deleting the Shader cache folder. Been getting smooth fps after a while of waiting for Cache to fill again. I like it.
  • CMKyriosCMKyrios
    MapleStory 2 Rep: 2,865
    Posts: 190
    Administrator
    edited 6:43PM April 17, 2019
    ElzaYuuki wrote: »
    Works great after deleting the Shader cache folder. Been getting smooth fps after a while of waiting for Cache to fill again. I like it.

    Interesting. Did this remove the unusual stutters too?

    Edit: You completely deleted the contents of the Shaders folder altogether?
  • battleflyerbattleflyer
    MapleStory 2 Rep: 600
    Posts: 5
    Maple Guide
    This isn't really an issue, but it felt like the game took a moment to load in the sprites/animations when the skill was first used in the 64 bit client, so that the game had a 0 fps spike when the game first starts. It does not seem to be reproducible, even after restarting the computer and loading the game again. It's only the first day so I can't pinpoint anything.

    In addition, I do not seem to see any notable difference in terms of fps optimization. Raids seems to be laggy as usual. I see maybe a slightly higher fps from low 20 to high 20 fps. Overall i guess an improvement but not by an amount notable.
  • ElzaYuukiElzaYuuki
    MapleStory 2 Rep: 1,460
    Posts: 33
    Member
    CMKyrios wrote: »
    Interesting. Did this remove the unusual stutters too?
    Edit: You completely deleted the contents of the Shaders folder altogether?

    Hmm yeah I haven't noticed any micro stutters anymore except for like the first hour. Also i just cleared my temp folder in C:/Windows and %temp% (just deleting the NVcache folder for Nvidia Cards is enough)

  • chaoscauserchaoscauser
    MapleStory 2 Rep: 950
    Posts: 16
    Member
    Stutters like crazy for me..